Windows::cek versi dan mode lisensinya

By human

Untuk melakukan pengecekan versi windows yang terinstall di pc anda, lakukan langkah-langkah di bawah ini :

  1. sebagai administrator, jalankan command promt, atau klik run dan ketik CMD
  2. Read more »

Roundcube::missing trash folder

By human

Getting error when delete mail from roundcube, this is happen because there’s no trash folder when the user login on first time.

To solve it, you can set create_default_folders in the Roundcube config to true (its default setting) to create the folders.

vi /etc/roundcube/defaults.inc.php

// automatically create the above listed default folders on first login
$config['create_default_folders'] = true;

get problem on
– Ubuntu 16.04.2 LTS
– roundcube 1.2~beta+dfsg.1-0ubuntu1

Mikrotik::PCQ Hotspot

By human

Di kopi dari tulisan Sudipta Kr.Pal di mum mikrotik, catatan pribadi supaya tidak lupa.
di tes memakai mikrotik versi 6.37.1

  1. Buat user profile baru
    /ip hotspot user profile \
            add incoming-packet-mark=Gold_IN name=Gold outgoing-packet-mark=Gold_OUT shared-users=1
  2. Buat queue type
    /queue type \
            add kind=pcq name=Gold_download pcq-classifier=dst-address pcq-rate=1m
            add kind=pcq name=Gold_upload pcq-classifier=src-address pcq-rate=1m
  3. Buat firewall mangle
    /ip firewall mangle
            add action=jump chain=forward jump-target=hotspot

Untuk step berikutnya silakan di tebak :)

Semoga bermanfaat

Trust+ : olah data untuk bind-mysql

By human

Setelah data dari situs trust+ kominfo di download, maka yang perlu di lakukan adalah insert data ke bind-mysql.
Karena datanya berjumlah ribuan baris, tidak mungkin di ketik satu-satu.

Untuk itu pergunakan script di bawah untuk mempercepat proses.

awk -F\; "{ print \"insert into dns_records (zone, host, type, data, mx_priority) values ('\" \$1 \"','*','CNAME','blok.isp.net.id.',null);\" }" datatrust.txt > semua.db

dimana :
datatrust.txt merupakan data trust yang sudah kita download.
semua.db merupakan output dari script yang tinggal kita inject ke bind-mysql.

Tambahan,
untuk konversi ^M menjadi newline bisa memakai aplikasi vi dengan perintah di bawah

:%s//\r/g
Where  means type Ctrl+V then Ctrl+M. 

Hapus duplikasi entry host.

 delete d1 from dns_records d1, dns_records d2 where d1.id > d2.id and d1.zone=d2.zone;

semoga bermanfaat

Excel: noted for me

By human

Removing the first X number of characters from a string in Excel and Google Spreadsheets

=RIGHT(B1,LEN(B1)-4)
2121886906.* become 886906.*

Delete text before or after character by formula in Excel

=LEFT(A1,FIND("s",A1)-1)

121s (2 minutes 1 second) become 121

Cisco:Drop Multicast

By human

Dapat pecerahan dari siniServer Fault tetapi belum di coba.

Di dokumentasi dulu, siapa tahu nanti dipakai.

If you want to shut down multicasts on an interface completely, use

storm-control multicast level 0 
switchport block multicast

The first command prevents inbound multicasts from entering the switchport. The second stops outbound multicasts from getting out.